Right, but without re-quoting everything from earlier, if you pick the names appropriately, you can do things like findobject('container'+n) where n varies from 0 to whatever. So you get the variability in accessing/finding objects so that you can then use getexpression/setexpression and the combination gives you the same result as the old (unsupported/more direct notation) of:Traxus wrote:Haven't messed with findobject yet, but it loos as though it takes a string of an objects node path as a paramater (rather than a raw object node path as per setexpression() or most other functions)?oldgearguy wrote: I also ran into this (see my posts a page or two back) and with liberal use of findobject() and getexpression() you can pretty much keep your data structure intact and use very similar code to access the info. I personally hate very long if..then..else constructs, so I worked hard to avoid that kind of code duplication.
decl ct = myContainer;
ct.knob2.x;
which no longer works.